The app works best with iOS10.3 and Android 7.1.1 (for most Android phones). We do not actively support iOS8 and earlier versions, or Android 4.4 and earlier versions. If your phone is running on such versions, please contact us at info@igloohome.co and we can arrange for a testing session at our office to see if it is compatible with our smart lock.


Please note that phone models tested were sold in Singapore. If your phone model was purchased from another country, it may not be supported as well.

For the list of compatible phone models: 
http://bit.ly/iglooCompatiblePhoneModels


Note: Please ensure that you have a compatible phone before purchasing an igloohome product. igloohome will not be responsible for troubleshooting phones not included in the list.